MPPG and QwickPAY degraded performance
Incident Report for Magensa
Resolved
All Magensa internal systems were fully operational. The cause for this performance degradation appears to have been due to regional ISP issues. If you continue to experience issues, please contact your ISP to see if they have any ongoing issues.
Posted Jan 19, 2018 - 23:39 UTC
Investigating
We have received reports of degraded performance with our MPPG and QwickPAY platforms. We are investigating and will provide updates as details emerge.
Posted Jan 19, 2018 - 23:06 UTC