Qwickcards service experiencing Pin issues
Incident Report for Magensa
Resolved
Issue is fully resolved.
Posted Oct 25, 2021 - 15:22 UTC
Update
We are continuing to investigate this issue.
Posted Oct 25, 2021 - 15:19 UTC
Update
Operational
Posted Oct 25, 2021 - 13:44 UTC
Investigating
We are currently investigating this issue.
Posted Oct 25, 2021 - 13:43 UTC