Magensa RS2/RS3 partial interruption in service.
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 22:12 UTC
Investigating
We are currently investigating this issue.
Posted Nov 22, 2022 - 23:00 UTC
This incident affected: Remote Services (RS2, RS3).