Service Resumed

Incident Report for Magensa

Resolved

The system is now back up and running.
Posted Jun 19, 2025 - 23:11 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 22:57 UTC

Investigating

We are aware of a Magensa Service interruption and are currently investigating.
Posted Jun 19, 2025 - 22:51 UTC
This incident affected: MPPG (All versions), Decrypt v1, Decrypt v2, Decrypt and Forward (All versions), QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3, RMS), www.MagTek.com, www.Magensa.net, www.QwickPAY.com, and Unigate.