Magensa Services Outage
Incident Report for Magensa
Resolved
The Magensa services interruption has been resolved.
Posted Aug 09, 2019 - 01:22 UTC
Identified
We have identified the issue and are attempting to resolve it.
Posted Aug 09, 2019 - 01:18 UTC
Investigating
Magensa services are experiencing an intermittent outage. We are working to resolve the issue.
Posted Aug 09, 2019 - 01:10 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, Remote Services (RS1), Remote Services (RS2), www.MagTek.com, www.Magensa.net, www.QwickPAY.com, and QwickCards.