Interruption in Magensa Services - traffic has returned to normal.
Incident Report for Magensa
Resolved
This issue has been resolved.
Posted Jul 26, 2021 - 17:30 UTC
Update
We are continuing to investigate this issue.
Posted Jul 26, 2021 - 17:30 UTC
Investigating
We are currently investigating this issue.
Posted Jul 26, 2021 - 17:19 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3), www.MagTek.com, www.Magensa.net, www.QwickPAY.com, and QwickCards - Instant Issuance.