*.magensa.net Domain Certificate Update
Incident Report for Magensa
Resolved
Project complete. The updated Magensa Server Certificates have been installed.
Posted Sep 28, 2022 - 20:08 UTC
Update
Please note: This update has no impact on client certificates. This update only affects the *.magensa.net server certificate.
Posted Sep 22, 2022 - 14:48 UTC
Investigating
The Magensa server certificate (*.magensa.net) will be updated on Wednesday, September 28th starting at 8:00AM PT. The new certificate uses a different DigiCert CA chain than the existing certificate. You are advised to check the certificate trust store on any system accessing a Magensa endpoint prior to this update to prevent a potential service access issue.


If you find that your certificate trust store needs to be updated manually, the CA can be downloaded from https://www.digicert.com/kb/digicert-root-certificates.htm.


Common Name = DigiCert Global Root CA
Serial Number = 08:3B:E0:56:90:42:46:B1:A1:75:6A:C9:59:91:C7:4A
Posted Sep 21, 2022 - 23:56 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, Remote Services (RS2, RS3), and www.Magensa.net.