Service interruption

Incident Report for Magensa

Postmortem

Microsoft identified a recent change that was strongly correlated with the onset of impact. They have completed the rollback of this change and telemetry across services are continuing to show signs of recovery.

Magensa Customers should observe recovery at this time.

We are closely monitoring service health and will provide additional updates if necessary.

Posted Jul 23, 2026 - 19:01 UTC

Resolved

Microsoft Azure services are now fully operational. The issue has been resolved.
Posted Jul 23, 2026 - 18:55 UTC

Update

We are awaiting updates from Microsoft, and we continue to explore additional options for restoring service.
Posted Jul 23, 2026 - 18:35 UTC

Monitoring

We have identified the current outage to be a Microsoft Azure issue that they are currently working on. Microsoft Response:
Microsoft has acknowledged the disruption and stated they are actively investigating the issue under incident ID MO1437424.

In the meantime, we have an alternative processing path that you can take advantage of.

Depending on the Magensa service you are using, replace your current endpoint URL with one of the following below (ie. If you are using MPPGv4, Replace your current endpoint with https://mppg.magensa.net/v4/MPPGv4Service.svc

Decrypt V2: https://decrypt.magensa.net/decrypt.svc (Client certificate and IP restricted)

Decrypt V3: https://decrypt.magensa.net/V3/decrypt.svc (Client certificate and IP restricted)
Decrypt and Forward (DAF) v3: https://daf.magensa.net/V3/Service.svc

Decrypt and Forward (DAF) v4: https://daf.magensa.net/V4/Service.svc
MPPG v3: https://mppg.magensa.net/v3/MPPGv3service.svc

MPPG v4: https://mppg.magensa.net/v4/MPPGv4Service.svc
Unigate: https://mppg.magensa.net/unigate

We will continue to update you as we get updates from Microsoft.
Posted Jul 23, 2026 - 17:08 UTC

Identified

We have identified the interruption as part of a broader Microsoft Azure health status issue. We will continue to investigate and provide updates as we further understand the situation.
Posted Jul 23, 2026 - 15:39 UTC

Investigating

We are aware of a service interruption with Magensa and are currently investigating. The outage began at 7:45 am PST. We will continue to provide updates as our investigation continues.
Posted Jul 23, 2026 - 15:15 UTC
This incident affected: MPPG (All versions), Decrypt v1, Decrypt v2, Decrypt and Forward (All versions), QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3, RMS), www.MagTek.com, www.Magensa.net, www.QwickPAY.com, and Unigate.