QwickCards and Remote Services not available.
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 17:46 UTC
Investigating
We are currently investigating this issue.
QwickCards is unavailable.
Remote Services unable to complete key change requests.
Posted Mar 03, 2023 - 17:17 UTC
This incident affected: Remote Services (RS2, RS3).