Notification: Changes to TLS Versions & Ciphers being implemented.
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted Oct 12, 2023 - 22:22 UTC
Update
Starting 8:00am (PT) on October 9th, 2023, Magensa will start removing CBC-based ciphers from mppg.magensa.net and decrypt.magensa.net service endpoints. This change is essential to align with current industry best practices and comply with PCI-DSS standards. Connection attempts that do not include a supported cipher will be rejected.
Posted Oct 09, 2023 - 14:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2023 - 17:19 UTC
Investigating
Starting 8:00am (PT) on October 2nd, 2023, Magensa will start removing CBC-based ciphers from all our service endpoints. This change is essential to align with current industry best practices and comply with PCI-DSS standards. Connection attempts that do not include a supported cipher will be rejected.

Notifications have been sent out recently regarding this change.
Posted Oct 02, 2023 - 15:11 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3), www.MagTek.com, www.Magensa.net, and www.QwickPAY.com.