Magensa services Unavailable.
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 18:47 UTC
Investigating
We are currently investigating this issue.
Posted Feb 22, 2023 - 17:14 UTC
This incident affected: MPPG, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, and Remote Services (RS2, RS3).