Magensa Transaction Processing Interruption
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted May 27, 2023 - 00:12 UTC
Monitoring
The issue has been identified and corrected. We are continuing to monitor the services.
Posted May 26, 2023 - 21:43 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2023 - 20:30 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3), www.MagTek.com, www.Magensa.net, and www.QwickPAY.com.