Customer Reported Connectivity Issues - researching.

Incident Report for Magensa

Monitoring

A remedy has been implemented and we are monitoring results.
Posted Sep 17, 2025 - 19:13 UTC

Investigating

We are investigating reports of intermittent connectivity/processing errors at this time.
Posted Sep 17, 2025 - 17:44 UTC
This incident affects: MPPG (All versions), Decrypt and Forward (All versions), and Unigate.