Upstream degradation or service outage
Incident Report for Magensa
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 22:56 UTC
Update
Services by many of the processors seem to be partially or fully restored
Posted Feb 26, 2021 - 21:34 UTC
Monitoring
We have received numerous notifications of service outages. All Magensa services are up and fully operational.

There are status page issues for the following processors: TSYS, WorldPay, Vantiv Core, Rapid Connect, Buypass, Chase Paymenttech, etc. We have some indication processors are having difficulty connecting with Visa and Mastercard.
Posted Feb 26, 2021 - 18:24 UTC