Magensa not impacted by CrowdStrike issue.

Incident Report for Magensa

Resolved

This incident has been resolved.
Posted Jul 24, 2024 - 20:32 UTC

Monitoring

Magensa has NOT been impacted by the CrowdStrike issue. All data centers are processing normal transaction loads. If you are experiencing wide-spread processing issues through Magensa service, please contact support@magensa.com for assistance.
Posted Jul 19, 2024 - 13:43 UTC
This incident affected: MPPG, Decrypt v1, Decrypt v2, Decrypt and Forward, QwickPAY Mobile/Virtual Terminal, Remote Services (RS2, RS3), www.MagTek.com, www.Magensa.net, and www.QwickPAY.com.