QwickCards Outage
Incident Report for Magensa
Resolved
All QwickCards services are fully restored and operational.
Posted Jul 08, 2017 - 16:36 UTC
Investigating
QwickCards is currently experiencing a service outage and we are actively researching the cause. Please bookmark this page as we will post updates as they become available.

http://magensa.statuspage.io/

The Magensa Team
Posted Jul 08, 2017 - 16:28 UTC