Magensa Service Outage
Incident Report for Magensa
Resolved
All Magensa services are fully restored and operational.
Posted Apr 10, 2017 - 17:55 UTC
Update
As of 8:55 AM PDT, we are continuing to investigate the service disruption. At this time, we do not have an ETA. We will notify you as soon as we have more information.
Posted Apr 10, 2017 - 15:57 UTC
Investigating
As of approximately 6:55 00 AM PDT, we are currently experiencing a service outage and are actively researching the cause. Please bookmark this page as we will post updates as we have information.

http://magensa.statuspage.io/

The Magensa Team
Posted Apr 10, 2017 - 14:25 UTC